Europe (UK) Status

Hero AI Degradation

Incident Report for Turbine Europe UK

Resolved

This Hero AI incident has been resolved after a sustained period of normal performance with no further issues observed.
Posted Dec 03, 2025 - 16:53 UTC

Monitoring

The Hero AI issue has been addressed and we are monitoring the solution.
Posted Dec 03, 2025 - 16:22 UTC

Investigating

Hero AI native actions are severly degraded while no other Turbine components are affected.
Posted Dec 03, 2025 - 16:04 UTC
This incident affected: Platform Status.